NUMERICAL MODELING OF THE EFFECTS OF TEMPERATURE ON EXPERIMENTAL MODAL ANALYSIS DATA

Trevor J. White¹, Andrew D. Sorensen, Ph.D.²

ABSTRACT

Experimental modal analysis (EMA) has become an accepted method for obtaining modal properties of existing and historic structures. EMA data has also been used as a resource for validating the boundary conditions and materials properties in finite element models (FEM). This is achieved by creating a FEM and comparing the obtained mode shapes with those obtained through EMA. The accuracy of the results of the FEM directly relies on the precision of its input parameters and how closely the FEM shapes match up with the experimentally obtained mode shapes. As this process is becoming more widely utilized, researchers have noticed discrepancies in the experimentally obtained data as a result of changes in the ambient temperature and humidity. These ambient environmental conditions affect the experimentally obtained mode shapes and frequencies. As this data is being used to determine the integrity of existing structures, it becomes necessary to find a numerical modeling procedure within the FEM which accounts for variances in the observed experimentally obtained mode shapes and fundamental frequencies as a result of changing temperature and humidity. This paper outlines a specific procedure for taking into account the variations in ambient temperature within a FEM using the software package ANSYS 13.0 ®. The method is demonstrated using a FEM of a simple masonry structure and verified with hand calculations. The results of this study will lead to a more accurately validated FEM that will provide better representation of the mechanical behavior of the structure under consideration.

Keywords: Experimental Modal Analysis, Temperature Effects on Masonry, Validated Finite Element Models

1. INTRODUCTION

Experimental modal analysis (EMA) provides a non-destructive method for identification of natural frequencies and mode shapes of existing structures [1]. This is obtained by placing accelerometers on the structure, exciting the structure by enacting an outside force, and recording the resulting motions throughout the structure. The recorded accelerations can be mathematically manipulated to produce frequency information, such as mode shapes, about the structure [2]. The experimentally obtained mode shapes can then be utilized to validate material properties and boundary conditions of a numerical model in a finite element modeling software program such as ANSYS 13.0 ® by comparison of the mode shapes and deflections. The validated finite element model (FEM) can they be manipulated to determine the performance of the structure under a wide variety of loading conditions. Using this validation procedure it is evident that the accuracy of the finite element model directly relies on the precision of the input parameters. Therefore any variation in the EMA data produces potential sources of error in the FEM.

Research on the use of EMA and other modal analysis experimental techniques have shown that variations in the ambient environmental conditions have an altering effect on the obtained mode shapes and natural frequencies [2-5]. Two widely observed ambient environmental effects that influence modal data in masonry structures are temperature and humidity. Depending on the

¹ Graduate Research Assistant, Dept. of Civil & Environmental Engineering, Idaho State University, whittrev@isu.edu
² Professor, Dept. of Civil & Environmental Engineering, Idaho State University, soreandr@isu.edu.
geographic location of a masonry structure, these ambient conditions may have large fluctuations on a daily basis that would distort modal data. In order to fully utilize the measured modal data as a validation tool in FEM’s of masonry structures, these variations must be accounted for. This paper discusses a method to account for variations in temperature within a FEM of a masonry structure using the software package ANSYS 13.0 ®.

1.1. Background
Researchers have provided many explanations as to why temperature has such an impact on the mode shapes of a masonry structure. One researcher suggests that the premise for the effect of temperature change influencing the modal data of a structure is attributed to the presence of a thermal expansion of materials associated with thermal strain [6]. Temperature changes can cause a masonry structure to either expand or contract. Because the boundary conditions of most structures are designed to be constant; at the base, expansion causes internal compressive stresses thermal contraction causes tensile stresses [6]. In the rest of the structure, the effects of thermal expansion and contraction have a reverse effect of respectively causing tensile and compressive stresses. The change in stresses within the structure modifies the stiffness of the structure leading to changes in the natural frequencies.
A differing theory suggests that temperature may have an altering effect on boundary conditions of the structure [7]. This may become apparent when freezing of the soil occurs; causing a discrepancy in the boundary conditions normally present in the structure. Changes in the boundary conditions may cause the structure to deflect differently as soil stiffness varies as a result of temperature changes. The boundary conditions of a structure are not usually considered to be temperature dependent. Additionally, it is assumed that it would take larger variations in temperature to effect such a reaction within the boundary conditions of a structure, and other research has shown that small variations in temperature can have noticeable effects on the measured natural frequencies [2, 8].

1.2. Problem statement
Although a significant amount of research has been conducted to determine a relationship between temperature, humidity, and their effect on natural frequency, there is no study providing a method for accounting for these variances in a FEM software package for masonry structures. This study presents a method to eliminate uncertainty with the verification of FEM using EMA data and coordinating measured ambient temperatures. The method used to accomplish this is to modify the material stiffness of a masonry structure prior to performing modal analysis in ANSYS 13.0 ®.

1.3. Review of literature
The effects of ambient environmental conditions have been studied in the past for a variety of structural materials. A brief summary of relevant past research is included below as a way to effectively organize, justify, and explain the research carried out in this study.
In one study, EMA data was used to monitor the structural health of two historical masonry structures. Along with the collection of EMA data, the corresponding ambient temperature and relative humidity were also collected [4]. The main purpose of the study was to determine a relationship between natural frequency, temperature, and humidity through interpretation of a wide range of collected data. The findings of the study effectively normalize the effects of temperature and humidity on natural frequency and suggest an adapted natural frequency which accurately portrays the characteristics of the structure. Through effectively normalizing the natural frequency, the authors were able to utilize modal analysis to determine whether damage has occurred to the historic structures on any given day. A similar study sought to quantitatively determine the relationship between modal analysis and ambient environmental effects on a scaled model of a masonry timbrel dome [2]. The analysis of the ambient environmental effects of this study points out a common trend between temperature and fundamental modal frequency; as ambient temperature increases, the first modal frequency also increases. Assuming a linear relationship between temperature and fundamental frequency, the authors suggest an adjustment to the measured frequency as a function of temperature.
Additional studies exist in which the authors develop an approach to remove the effects of temperature and humidity on fundamental frequency. One suggested strategy is to model the structure with a temperature dependent modulus of elasticity which would alter the stiffness of the structure as a result of a change in temperature [9]. Another suggested solution is to effectively develop a range of acceptable frequencies based on temperature differences [7]. This is done by modeling a structure with temperature dependent material properties and analyzing a model throughout a range of temperatures. If the
measured frequency does not lie within the range developed in the modeling technique, then damage can be assumed to have taken place within the structure. One more study suggests using a method called “Principal Component Analysis” for determining and identifying ambient effects on modal analysis [3]. Using this method, the authors attribute the changes in natural frequency to a temperature dependent modulus of elasticity. This approach has been successful in determining damage identification due to changes in mode shapes while eliminating uncertainty due to varying temperatures.

2. MODELING PROCEDURE

In order to demonstrate this modeling procedure in ANSYS 13.0®, a simple example of a cantilever masonry wall will be used. The wall dimensions are 2.44 m long × 2.44 m high × 0.009 m wide (96 in. × 96 in. × 3.5 in.).

After the geometric representation and boundary conditions are input into the FEM, an element suitable for representing masonry must be defined. According to the existing literature [10-12], an element type of SOLID45 is recommended. The help section in ANSYS Release 13.0® suggests an updated element type in place of SOLID45. As a result of this suggestion, the SOLID186 element type has been utilized for its 3-D nodal translations, creep, stress stiffening, large deflection, and large strain capabilities. Rather than modeling the mortar and the brick as separate elements, the existing literature suggests that modeling masonry structures as a single component, with a composite modulus of elasticity and Poisson’s ratio, renders an acceptably accurate representation of masonry [11, 12]. After development of a solid element, the material properties of the masonry wall to be analyzed must be entered. The material properties utilized for this report have been selected in accordance with relevant research [10] and ACI 122R [13]. These material properties are displayed in Table 1.

<table>
<thead>
<tr>
<th>Material Property</th>
<th>Value: Metric (English)</th>
<th>Units: Metric (English)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modulus of Elasticity</td>
<td>10.34 (1500)</td>
<td>GPa (ksi)</td>
</tr>
<tr>
<td>Thermal Conductivity</td>
<td>166.8 (0.102)</td>
<td>kJ/h-m² (Btu/(hr-ft²))</td>
</tr>
<tr>
<td>Density</td>
<td>192.01 (0.0002156)</td>
<td>kg/m³ (Slug/in³)</td>
</tr>
<tr>
<td>Coefficient of Thermal Expansion</td>
<td>0.000105</td>
<td>1/C</td>
</tr>
<tr>
<td>Specific Heat</td>
<td>0.2</td>
<td></td>
</tr>
<tr>
<td>Poisson’s Ratio</td>
<td>0.24</td>
<td></td>
</tr>
</tbody>
</table>

The FEM wall is meshed with a set edge length of 0.009 m. (3.5 in.) using a hexagonal mapped mesh to ensure that there will be one element in the thickness of the wall. After meshing the masonry wall it becomes necessary to define the loads and boundary conditions present on the structure. For the modal analysis, a structural displacement of zero has been placed on the bottom face of the wall. This represents a fixed boundary condition. An ANSYS 13.0® rendering of the meshed wall with the cantilevered boundary conditions is shown in Figure 1.

![Fig. 1 Meshed Masonry Wall with Boundary Conditions FEM](image)
In order to strategically alter the stiffness of the structure due to thermal loading, thermal loads corresponding to varying temperature, are placed on the volume of the wall. The structural temperature load is interpreted in ANSYS 13.0 ® as an adaptation to the physical properties of the SOLID186 masonry element since the coefficient of thermal expansion, thermal conductivity, and specific heat have been specified in the material model. This adaptation has the effect of stressing the structure due to the strains associated with thermal expansion against the fixed cantilevered boundary conditions. The expansion or contraction of the SOLID186 element alters the properties of the model. This pre-stressing is used to alter the model utilizing only the addition of a temperature load.

Research has been conducted to determine a baseline reference temperature for masonry from which thermal expansion or contraction occurs [2, 13]. Based on these studies a baseline value of 30° Celsius is chosen for this study. The resulting stresses are obtained for temperatures of 0, 5, 10, 15, 20, 25, 30, 35, 40, 45, and 50° Celsius. The resulting structural stresses obtained for each temperature are then applied to the structure as pre-stressing forces on the SOLID186 element and the modal analysis is then carried out. This pre-stressing alters the properties of the masonry wall which results in changes to the mode shape and resulting natural frequency. An example of the presentation of stresses due to thermal expansion can be seen in Figure 2, and an example of the stresses due to thermal contraction can be seen in Figure 3.

A step-by-step guideline showing explicit details on the modeling procedure in ANSYS 13.0 ® utilized in this study is shown below:

- Pre-processor > Element Type > Add/Edit/Delete > Add > Structural Mass > Solid > 20node186 > Ok
- Pre-processor > Material Properties > Temperature Units > Celsius > Ok
- Pre-processor > Material Properties > Material Models > Material Model Number 1 >
  - Structural > Linear > Elastic > Isotropic > EX = 1500E3 psi or 10.34E9 Pa, PRXY = 0.24
  - Structural > Density = 0.0002156 Slug/in³ or 192.01 Kg/m³
  - Structural > Thermal Expansion > Instantaneous Coefficient > Isotropic > Ref. Temp = 30, CTEX = 0.000105 1/°C
  - Thermal > Conductivity > Isotropic > Kxx = 0.102 BTU/(h-in²) or 166.8 KJ/(h-m²)
  - Thermal > Specific Heat > C = 0.2 > Close Material Models
- Pre-processor > Modeling > Create > Volumes > Block > By 2 Corners & Z >
  - WPX = 0
  - WPY = 0
  - Width = 96 in. or 2.44 m
  - Height = 96 in. or 2.44 m
  - Depth = 3.5 in. or 0.099 m
  - > Ok
- Pre-processor > Meshing > Mesh Tool > Element Attributes > Volumes > Set > Select Volume > Ok
- Pre-processor > Meshing > Mesh Tool > Size Controls > Set > Areas > Select All Areas > Size Element Edge Length = 3.5 in. or 0.099 m. > Ok
- Pre-processor > Meshing > Mesh Tool > Mesh > Volumes > Shape = Hex Mapped > Mesh > Select Volume > Mesh > Close Mesh Tool
- Solution > Analysis Type > New Analysis > Static > Ok
- Solution > Analysis Type > Sol’n Controls > Analysis Options > Small Displacement > Calculate Prestress Effects To On > Ok

Fig. 2. Thermal Expansion (40°C)  
Fig. 3. Thermal Contraction (20°C)
3. RESULTS

By applying thermal stresses on the simple masonry wall the properties of the wall are changed. Forcing ANSYS 13.0 ® to interpret these material property changes as an effective prestressing of the structure prior to modal analysis, reveals a change in the fundamental mode shape as a function of temperature. The modifications of the first mode shape represented in ANSYS 13.0 ® follow the trend found by other researchers for changes in temperature. Typically, as ambient temperature increases the fundamental frequency will also increase [2, 8]. Utilizing thermal stresses, the first mode shape of the masonry wall has been computed for various temperatures in ANSYS 13.0 ®. The results are shown in Figure 4.

As previously mentioned, the ANSYS 13.0 ® results have also been verified utilizing hand calculations. These hand calculations involve the use of standardized equations for defining the stiffness and modal mass of the wall for determining the natural frequency. The equation for the modal mass of the cantilevered wall is given as [14]:

\[ m_{eq} = M + 0.32m \]  

(1)

where: \( m_{eq} \) = equivalent mass of a cantilever wall, \( M \) = end mass, \( m \) = mass of the wall

Since the wall does not contain an end mass located at the top of the wall the equivalent mass of the simple wall simplifies to 0.23m. The equation for defining the stiffness of the wall is given as [14]:

\[ k_{eq} = \frac{3EI}{h^3} \]  

(2)
where: \( k_{eq} = \) equivalent modal stiffness, \( E = \) modulus of elasticity of masonry, \( I = \) moment of inertia of wall, \( h = \) height of wall.

The fundamental natural circular frequency of the masonry wall is then calculated using the simplified formula for a single degree of freedom system [14]:

\[
\omega_n = \sqrt{\frac{k_{eq}}{m_{eq}}}
\]

where: \( \omega_n = \) natural circular frequency, \( k_{eq} = \) equivalent modal stiffness, \( m_{eq} = \) equivalent mass of a cantilever wall.

Current research suggests that modulus of elasticity, moment of inertia, and height are all temperature dependent [15]. However, for the purpose of this study the modulus of elasticity is assumed to have little variance for the experienced temperatures of a masonry structure. Therefore the moment of inertia and height of the wall have been calculated in accordance with the coefficient of thermal expansion. A linear modification of the height, length, and width of the wall has been performed by multiplying the initial length by the temperature and the coefficient of thermal expansion. As previously described, a baseline of 30° C has been used to determine whether thermal contraction or expansion has occurred. Using equations (1), (2), (3), and the thermal modifications of the structure the natural frequency is calculated for the temperature range of 0° C to 50° C. The results of the FEM and the hand calculations are shown as a function of the applied temperature in Figure 4.

![Fig 4 First Mode Shape vs. Temperature](image)

Comparison of the ANSYS 13.0 ® results with the hand calculated results reveals a good correlation for the data. Both follow a positive linear trend and both results are relatively close in magnitude for all temperatures considered. Comparison of the hand calculations and the FEM yields an average percent difference of 0.39%. This percentage of error is considered to be acceptable thus showing that the modeling technique presented earlier produces accurate results. More importantly, both calculations show the same linear trend observed in the previous findings [2, 8].

### 4. CONCLUSION

This paper has demonstrated a finite element modelling procedure to account for the effects of different temperatures on measured modal data for masonry structures. A summary of the procedure follows:

1. Define an element type of SOLID186 to represent masonry
2. Specify the thermal units to be used in the model
3. Enter the structural and thermal material properties of the masonry to be modeled along with a reference temperature pertaining to the coefficient of thermal expansion
4. Construct the model of the masonry building
5. Mesh the model
6. Apply the boundary conditions, thermal load, and solve a static analysis
7. Enter Post-Processing to view and save the static analysis
8. Start a new modal analysis in which the model is selected to include prestress effects
9. Solve the modal analysis
10. Enter Post-Processing to view and save the modal analysis

4.1. Further Study
Future research is necessary for validating the methodology of this study for differing geometries of structures. The change to a more complex structure may ultimately result in changes in the accuracy of the ANSYS 13.0 ® model. Another topic which may need addressing is the temperature dependence of the modulus of elasticity of masonry. Implementation of this variable into the modeling procedure may account for the discrepancy between the hand calculations and the ANSYS 13.0 ® output. Additionally, as previous studies have shown that ambient relative humidity also affects measured modal data, further studies to determine modelling procedures to account for this are warranted.

5. REFERENCES